Unofficial Allis Homepage
Forum Home Forum Home > HELP! > Forum Support Only - No Tractor Questions
  New Posts New Posts
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Hydraulic pump

 Post Reply Post Reply
Author
Message
Chad190xt View Drop Down
Bronze Level
Bronze Level
Avatar

Joined: 22 May 2020
Location: NY
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Chad190xt Quote  Post ReplyReply Direct Link To This Post Topic: Hydraulic pump
    Posted: 22 May 2020 at 8:07pm
Looking for help , I have a 190xt that I put in shop over 6 months ago to redo, I pulled the oil cooler off and replaced lines from cooler to pump, never removed the pump, I changed the filter , cleaned sump screen , changed oil, so now with that all being done , it’s very choppy to steer and the pump makes a squealing noise, I was told my pump is going bad , I have also pulled the plunger out of pump and that’s not sticking , looking to not buy a pump at 2 grand maybe there is something I’m over looking any help would be greatly appreciated
Back to Top
Sponsored Links


Back to Top
 Post Reply Post Reply
  Share Topic   

Quick Reply
Name:

Message:
   NoFollow is applied to all links from this forum
 Enable BBcodes
Security Code:
Code Image - Please contact webmaster if you have problems seeing this image code  Refresh Refresh Image
Powered by Web Wiz CAPTCHA version 4.04 wwf
Copyright ©2005-2013 Web Wiz
Please enter the Security Code exactly as shown in image format.
Cookies must be enabled on your web browser.

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.063 seconds.


Help Support the
Unofficial Allis Forum