Unofficial Allis Homepage
Forum Home Forum Home > Allis Chalmers > Farm Equipment
  New Posts New Posts
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Allis Chalmers EB Has No Power

 Post Reply Post Reply
Author
Message
Valiant Farmer View Drop Down
Bronze Level
Bronze Level
Avatar

Joined: 30 Nov 2019
Location: New Zealand
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote Valiant Farmer Quote  Post ReplyReply Direct Link To This Post Topic: Allis Chalmers EB Has No Power
    Posted: 14 Dec 2019 at 3:24am
Hi all,

My Brother and I have been fixing up my Allis Chalmers EB.

We have reset the timing, it sounds better but it has little to no power.

It can just start off in 1st gear but it dies soon after.

What should I do now?

We don't know much about magneto ignition.

We would be grateful for any help!

Thanks!
Samuel

Edited by Valiant Farmer - 14 Dec 2019 at 3:24am

PSALM 119:105 : Thy word is a lamp unto my feet, and a light unto my path.
Back to Top
Sponsored Links


Back to Top
Sugarmaker View Drop Down
Orange Level
Orange Level
Avatar

Joined: 12 Jul 2013
Location: Albion PA
Points: 5637
Post Options Post Options   Thanks (0) Thanks(0)   Quote Sugarmaker Quote  Post ReplyReply Direct Link To This Post Posted: 14 Dec 2019 at 7:15am
Sam,
I would recheck the fuel flow/ carb.
Could be more than one fouled plug??
Good news is it runs, so it is probably a minor issue.
 Regards,
 Chris


Edited by Sugarmaker - 14 Dec 2019 at 7:16am
D17 1958 (NFE), WD45 1954 (NFE), WD 1952 (NFE), WD 1950 (WFE), Ford Jubilee, IH TD6 Many IH Cub Cadets
Back to Top
Stan IL&TN View Drop Down
Orange Level
Orange Level
Avatar

Joined: 13 Sep 2009
Location: Elvis Land
Points: 6471
Post Options Post Options   Thanks (0) Thanks(0)   Quote Stan IL&TN Quote  Post ReplyReply Direct Link To This Post Posted: 14 Dec 2019 at 9:30am
Did it have good power before you started fixing it up? If it did then I would consider undoing what has been done. If not then I would proceed as Chris has suggested.
1957 WD45 dad's first AC

1968 one-seventy

1956 F40 Ferguson
Back to Top
Boss Man View Drop Down
Silver Level
Silver Level


Joined: 03 Mar 2018
Location: Greenleaf, WI
Points: 119
Post Options Post Options   Thanks (0) Thanks(0)   Quote Boss Man Quote  Post ReplyReply Direct Link To This Post Posted: 14 Dec 2019 at 9:32am
Did you check compression? Change plugs and wires? Check that the plug wires are in the right order?
Back to Top
chaskaduo View Drop Down
Orange Level
Orange Level
Avatar

Joined: 26 Nov 2016
Location: Twin Cities
Points: 3407
Post Options Post Options   Thanks (0) Thanks(0)   Quote chaskaduo Quote  Post ReplyReply Direct Link To This Post Posted: 14 Dec 2019 at 9:58am
Can you rev her up. If so, does she still do the same when revved up. 
1938 B, 79 Dynamark 11/36 6spd, 95 Weed-Eater 16hp, 2010 Bolens 14hp
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.043 seconds.


Help Support the
Unofficial Allis Forum