Unofficial Allis Homepage
Forum Home Forum Home > Allis Chalmers > Farm Equipment
  New Posts New Posts
  FAQ FAQ  Forum Search   Events   Register Register  Login Login


Allis 5050

 Post Reply Post Reply
Author
Message
capn lonnie View Drop Down
Bronze Level
Bronze Level
Avatar

Joined: 20 Nov 2011
Location: maryland
Points: 27
Post Options Post Options   Thanks (0) Thanks(0)   Quote capn lonnie Quote  Post ReplyReply Direct Link To This Post Topic: Allis 5050
    Posted: 19 Apr 2021 at 3:19pm
My 5050 keeps spitting hydraulic fluid out of the vent cap that is located by the PTO lever.I replaced the hydraulic pump filter thinking it was plugged, but no help. Anyone have any ideas on why this is happening? Thanks!
'44 B '46 C '58 D-14 '78 5050
Back to Top
Sponsored Links


Back to Top
Steve in NJ View Drop Down
Orange Level Access
Orange Level Access
Avatar

Joined: 12 Sep 2009
Location: Andover, NJ
Points: 10262
Post Options Post Options   Thanks (1) Thanks(1)   Quote Steve in NJ Quote  Post ReplyReply Direct Link To This Post Posted: 19 Apr 2021 at 5:42pm
Could be a few things. Vent cap not venting properly, air getting into the system somewhere causing some cavitation, and once the air pocket gets purged back to the tank, causes things to spew out. Possible hose collapsing internally causing a restriction issue...
Steve@B&B
39'RC, 43'WC, 48'B, 49'G, 50'WF, 65 Big 10, 67'B-110, 75'716H, 2-620's, & a Motorhead wife
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.078 seconds.


Help Support the
Unofficial Allis Forum